PHOTOSHOP CS
TUTORIAL 10
Isolating Image Parts
Extract objects. Cut out an image. Remove a background. Call it what you will, each of these phrases describes the same objective: take a photo and isolate an object in it from the rest of the image, without the background.

Browse any major e-commerce site and you'll see this kind of imagery used heavily within product catalogues – various household items set against a blank white background.
Once an item has been separated from its background then it can easily be transplanted into another photo, or used as part of a complex repair operation.
Isolating a subject with fine details could be time-consuming and frustrating with the techniques we’ve dealt with previously. You might try to use the lasso tool to outline the edges of the object (and then have to start all over when your mouse slips), or use the eraser brush to painstakingly wipe away pixels from the edges of the object. But a few attempts with these techniques result in crossed eyes and the beginnings of a migraine headache.
In this tutorial, we'll explore four different methods to isolate objects in Photoshop CS. 
The methods covered here include:

· Using Photoshop's Magic Eraser tool
· Using Photoshop's Background Eraser tool
· Using the Extract command
· Using the Magnetic Lasso tool to make a selection
Methods that we’ve covered previously that would also work include:

· Using Quick Mask mode
· Using the Colour Range menu item
There are many tools in Photoshop used for masking or isolating a part of an image.  When you need to do this, it’s all about choosing the right tool for the job.  There are references to further material at the end of this tutorial that will give you other examples of uses of these techniques.
Saving an image from the L drive
1. Once you have logged in to Windows XP, load Windows Explorer.  Go to “L:\CMPCP0023\Tutorial 10\Samples” and copy all the photos to your desktop.

2. Load Photoshop CS via the Start Menu
Bee

3. Locate the photo “Beetoy.jpg” that you previously saved to your desktop and open it in Photoshop.

Note: If you have control over the photography, a good rule of thumb is to try to provide a solid-coloured background that contrasts with your object.
The Magic Eraser Technique
Explanation: The Magic Eraser tool (hold down the Eraser icon in the toolbar to access it) allows you to erase pixels that are all the same colour (or are a similar colour). If you used the Magic Eraser tool at its strictest setting, and clicked on a part of the picture that was orange, every other pixel in the picture of that exact shade of orange would be erased. We'll use the Magic Eraser tool to erase the whites and greys in this photo.
First, we'll change a few of the tool settings. By increasing the Tolerance, the Magic Eraser tool will erase a wider range of "similar" colours as well (whites/greys). By checking the "Contiguous" box, the Eraser tool will only grab pixels of similar colours that are next to each other -- that way, we won't accidentally erase the whites of the bee's eyes.
4. Select the Magic Eraser tool (hold down the Eraser icon in the toolbar to access it).

5. Set the Tolerance to 72, and make sure that “Contiguous” is checked.

6. Click outside of the bee, in the "white" area.
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Note: If the Tolerance is too high, you might inadvertently erase some bits of the object as well. If that's the case, just Undo and try a slightly lower Tolerance level.
7. Set the Tolerance to 32, and make sure that “Contiguous” is checked.

8. Click on the remaining grey ‘shadowy’ areas to the lower-right of the bee.

9. If the bee is affected too, then Undo and either try clicking in a lighter part of the shadowy area, or reduce the tolerance and try again.  Do a few clicks if necessary to remove any remaining shadow.

10. Double-click on the Background layer in the layers palette, click OK when prompted.

11. Go to menu Layer -> New -> Layer…, click OK when prompted.

12. Go to menu Edit -> Fill.

13. In the first combo box, choose “Colour…”.  Choose a bright-red colour. Then click OK.

14. In the layers palette, drag the new layer that we have just created beneath the toy layer.

Explanation: It’s often easier to see what you have remaining when you have a strong contrasting layer behind, this is what our red layer is for here.  It should enable you to better detect any flaws.

15. If required, use the standard eraser tool to remove any remaining unwanted parts, and use the History Brush to fix anywhere that has had too much chipped away. 
16. Use menu File -> Save As to save a copy of this version of the image if you wish.

Technique Summary - Magic Eraser:

This technique makes it easy to isolate objects that are on solid-coloured backgrounds, although you may need to spend some time with touch-up. Beware of stray pixels and can be hard work using this technique if you have a multi-coloured background!
The Background Eraser Technique
The Background Eraser Tool (again, hold down the Eraser tool to access this option) is meant to be used along the edges of an object. The centre of the brush determines which similar colours to erase. The Background Eraser Tool will also change the edges of an object slightly so that you don't get a "colour halo." We'll use the Background Eraser Tool to isolate and define the edges of the object, then erase the other pixels on the "outside."
17. Use menu File -> Revert, to restore the image to how it was when it was first opened.

18. Select the Magic Eraser tool (hold down the Eraser icon in the toolbar to access it).

19. Make sure that Sampling is set to Continuous, set tolerance to about 28%, brush size to about 40 pixels
Note: You'll see a round cursor with a crosshair in the centre. The important thing is to keep the crosshair from touching the actual object (if it does, the object will be erased). So, as you draw along the outside of the object, keep the crosshair just outside the object. You'll see that the outside's "similar colours" start to be erased.
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20. Start drawing around the outside of the toy so that the crosshair never touches the toy. Continue around the entire object. You may notice that parts of the image get "eaten away." Don't worry – we'll use the History Brush later to bring those parts back (a lower tolerance might reduce the occurrence of this).
21. Once you have completed drawn an ‘erased border’ around the entire toy - Select the Magic Wand tool, set the Tolerance to 100, check the Contiguous box, and then click on the background.
22. Press the Backspace key to delete the background. Use the Eraser tool to clean up any obvious stray pixels.
23. Double-click on the Background layer in the layers palette, click OK when prompted.

24. Go to menu Layer -> New -> Layer…, click OK when prompted.

25. Go to menu Edit -> Fill.

26. In the first combo box, choose “Colour…”.  Choose a bright-red colour. Then click OK.

27. In the layers palette, drag the new layer that we have just created beneath the toy layer.

28. If required, use the standard eraser tool to remove any remaining unwanted parts, and use the History Brush to fix anywhere that has had too much chipped away. 
29. Use menu File -> Save As to save a copy of this version of the image if you wish.

Technique Summary - Background Eraser:

This technique works in a similar way to the magic eraser tool, but limits its effect to the area over which you are painting, and continually adapts to local colour conditions - meaning that it is always using the colour beneath the cross-hair as a reference of the colour that it needs to be removing.

The Extract Filter Technique
The Extract Filter is designed to extract objects with fine details from a background.  The initial stage is to paint over the outline of the object (green) – covering any area that contains both elements of background and object. Secondly, once an area has a border, any part of the image that should be kept in its entirety should be filled (blue).

30. Use menu File -> Revert, to restore the image to how it was when it was first opened.

31. Use menu Filter -> Extract…

32. Select the Brush tool (top-left).

33. Draw an outline around the object you wish to extract. The outline should overlap both the object and the background. Use a Brush size that is big enough for you to outline comfortably, but small enough to outline any details of the picture. (You may switch Brush sizes while you're outlining.)
[image: image3.png]



34. When you've completed the outline, change to the Paint Bucket tool. 
35. Fill the areas that you wish to "keep" with the paint bucket tool – i.e. click in the middle of the toy.

36. Click the Preview button to see how the object appears when extracted.
37. If the result is about right, click OK to accept the Extraction.

38. Double-click on the Background layer in the layers palette, click OK when prompted.

39. Go to menu Layer -> New -> Layer…, click OK when prompted.

40. Go to menu Edit -> Fill.

41. In the first combo box, choose “Colour…”.  Choose a bright-red colour. Then click OK.

42. In the layers palette, drag the new layer that we have just created beneath the toy layer.

43. If required, use the standard eraser tool to remove any remaining unwanted parts, and use the History Brush to fix anywhere that has had too much chipped away. 
44. Use menu File -> Save As to save a copy of this version of the image if you wish.

Technique Summary – Extract Filter:

For the purposes of this image, the Extract Filter seems to involve more work for no extra benefit.  However, the Extract Filter is well suited to images with lots of fine details that would normally prove difficult to separate from their background (like hair blowing in the wind, tree branches, etc.) – unlike this image.

The Magnetic Lasso Technique
45. Use menu File -> Revert, to restore the image to how it was when it was first opened.

46. Select the Magnetic Lasso Tool from the toolbox (hold down the Lasso icon in the toolbar to access it).

47. Click as accurately as you can on one of the outside edges of the toy, then carefully move your mouse cursor slowly around the entire edge of the toy.  You should notice that Photoshop will drop anchors that are ‘magnetically’ attracted to the edge of the toy.

48. If you need to help Photoshop out - to define a sharp corner for instance – just click the left mouse button to create an additional anchor.
49. When you reach the starting point the mouse cursor will change to have a small circle next to it.  Click here to finish the selection.  Alternatively if you can’t find this exact spot – double click to end the selection.
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50. Once you’re satisfied with your final selection, go to menu Select -> Inverse, then hit the Backspace key to erase the background.
51. Use menu File -> Save As to save a copy of this version of the image if you wish.

Technique Summary – Magnetic Lasso:

This method works for any object that has crisp, hard edges, regardless of the background (although backgrounds with similar colouring to your subject will confuse Photoshop). It is also quite precise. It's reasonably fast if you're comfortable with using the Pen Tool; otherwise, this method might take a long time! You may find that you have a slight colour halo around the object as it may pick up some of the background colours.
Some New Challenges
Note: You're now aware of a whole range of tools for separating an image from its background.  Try your skills on the following images, use any technique (or combination of techniques) that you think may work or would like to experiment with. 
Hike
52. Locate the photo “Katie, 18 Mile Hike.jpg” that you previously saved to your desktop and open it in Photoshop.

53. Adjust the Levels appropriately.

54. Select the Rectangular Marquee tool from the tool box.
55. Press CTRL-A to select the entire image (or alternatively menu Select -> All)
56. Press CTRL-C (or alternatively menu Edit -> Copy)

57. Close the Hiking image
58. Locate the photo “Mont Blanc Summit.png” that you previously saved to your desktop and open it in Photoshop.

59. Press CTRL-V (or alternatively menu Edit -> Paste)

Explanation: In the following steps, we’re going to attempt to remove the background from the ‘hiking’ image, so that it appears as if Katie was standing on top of Mont Blanc when the photo was taken. 

60. Use any techniques you like to remove Katie’s background.  Make sure that the edges are good (zoom in to check the detail).
61. Adjust the Levels of the background and/or Katie to try and make a better colour match.

Frizzy Hair

62. Locate the photo “Frizzy Hair.jpg” that you previously saved to your desktop and open it in Photoshop.

63. Adjust the Levels appropriately to remove the colour cast.

64. Use any techniques you like to remove the background.  Make sure that the edges are good (zoom in to check the detail).

65. Copy the extracted image, and paste it onto “Boats, Seattle.JPG”.  Scale as necessary, and adjust the Levels of the Boats image appropriately.

Summary
Here's a quick summary of the different methods and when they're best used.
1. The Magic Eraser Technique
Great for erasing backgrounds that are mostly all the same colour that contrast with the object (set a high tolerance and use one click!), but may involve a bit of touch-up work at the end. Not ideal for objects that are on multi-coloured backgrounds.

2. The Background Eraser Technique

This technique allows greater control than the magic eraser, and continually adapts based on the colour beneath the cross-hair.
3. The Extract Filter Technique

Works best for erasing the background around objects with fine details such as frizzy hair or branches.
4. The Magnetic Lasso

Almost the ideal solution: relatively quick, pixel-perfect control over edges, and works with any kind of background.
Hopefully you should now have a better idea of the most appropriate time to use each ‘weapon’ in your Photoshop arsenal.

Please look here - http://designorati.com/photoshop/2005/removing-backgrounds-part-1-the-background-eraser-tool/ - for a detailed guide on using some of the tools and techniques we’ve looked at today.
